ホーム > TTSneoのお知らせ > 詳細

TTSneo1.42へ更新する場合の注意

TTSneo1.42では、一部の機能を大幅に修正しました。

そのため、仕様変更や不具合が原因で、以前作成したプログラムが実行できなくなることがあります。
TTSファイルやDLL版で作成したものは、更新することで、動作しなくなる可能性があります。

使用できなくなると困る場合は、実行可能形式を(DLL版以外で)作成するなどしてからインストールしてください。

また、作成したTTSファイルをあらかじめバックアップすることを強くお勧めします

※以前のバージョンも公開していますので、動作が安定しない場合は、以前のバージョンに戻すこともできます

 

仕様変更

拡張オブジェクト・「情報」関数の廃止
永遠に繰り返せの仕様変更
キーボード関連手順名の変更
メニューでショートカットキーが設定可能に
「もし」文の仕様変更
「分岐」文の仕様変更
オリジナル命令の改良(試験段階)

不具合の修正

・「並び替え」命令で「名前順」を指定すると、大文字と小文字が区別される問題、直前に行った並び替えが反映されない不具合を修正 New!(7/15)

・「合計」「平均」「偏差値」関数で、「,」が含まれる数字が正しく処理されない不具合の修正

・表の「一覧」設定項目に関する不具合の修正
 →「,」が含まれる文字列があると配列が壊れる問題
 →「一覧」設定項目を設定しても、セルの幅が統一されない、行列数が変わらない問題
 →「全一覧」設定項目が指定できない問題

→サンプル(ミニ表計算.tts)を改良しました

細かい改良点

・リストビューの見出し(カラム)をクリックすると自動的に並び替えを行うように改良 New!(7/15)

・「合計」「平均」「偏差値」関数で2次配列全体でも計算できるように改良
2次配列のすべての要素から合計を検索することができるようになりしました。

拡張オブジェクト・「情報」関数の廃止

以前から廃止予定でした拡張オブジェクトと「情報」関数を完全に廃止します。

TTSneo1.41以降は、
 ・拡張オブジェクトの変わりに、「利用」命令を
 ・「情報」関数の変わりに、配列を
利用してください。

永遠に繰り返せの仕様変更 New

「繰り返せ」命令で無限に繰り返しする場合、「永遠に」を指定する必要がなくなりました。

従来

永遠に繰り返せ
・・・
繰り返し終わり

最新版

繰り返せ
・・・
繰り返し終わり

 

キーボード関連手順名の変更 New

オブジェクトのキーボードに関する手順の名称を変更・統一しました。

’キーボードのすべてキーの動作に反応
手順は [オブジェクト名]のキーボードを押す
手順は [オブジェクト名]のキーボードを離す
手順は [ウィンドウ名]のキーボード[キー]を押す
手順は [ウィンドウ名]のキーボード[キー]を離す

’英数字など入力可能な文字のみに反応
手順は [オブジェクト名]に入力
手順は [オブジェクト名]に[文字]を入力

「入力」手順は、文章テキスト以外のオブジェクトにも対応しました。

これらの手順が実行されたときに、押されたキーは、「押したキー」・「押したキー番号」関数で取得することができます。

キーボード手順の実行順番

ウィンドウのキーボード手順 → 各オブジェクトのキーボード手順(対応している場合)

キー名称の変更

[キー]で指定するキーの名称を分かりやすい表記に変更しました。
詳しくは、リファレンスの「キーボードの番号一覧」をご覧ください。

〜のキーボード112を押す → 〜のキーボードF1を押す
〜のキーボードエンターを押す → 〜のキーボードEnterを押す
〜のキーボード32を押す → 〜のキーボードSpaceを押す
〜のキーボード39を押す → 〜のキーボード→を押す

廃止された手順 New(8/12)

手順名の統一のため、最新版では以下の書き方では動作しません。

手順は [オブジェクト名]のキーボード[キー]を押す
手順は [オブジェクト名]の[キー]を押す
手順は キーボード[キー]を押す

 

[キー]を指定した手順は、ウィンドウのみで対応し、各オブジェクトでは判別できなくなりました。
そのため、各オブジェクトで押したキーに応じて処理を変えるには、下のように「押したキー」関数を利用してください。

手順は ウィンドウ1の入力選択リスト1でキーボードエンターを押す
  ・・・・
終わり

 ↓↓↓↓

手順は ウィンドウ1の入力選択リスト1でキーボードを押す
もし 押したキーは、「Enter」 なら
  ・・・・
もし終わり
終わり

 

関連情報

キーボードの番号一覧 (手順名に指定するキー名称はこちら)
キーボードの手順 (キーボードに関する手順の説明)

 

メニューでショートカットキーが設定可能に New

以前は、メニューにショートカットキーを割り当てることができませんでしたが、最新版よりメニューの「ショートカットキー」設定項目で、ショートカットキーを割り当てることができるようになりました。

この変更により、キーボード関連手順を使ってショートカットキーを割り当てる必要が無くなり、余分な手順を減らすことができます。

’ショートカットキーの設定
メニューのファイル(&F)の開くのショートカットキーを、「Ctrl+O」に変えろ
メニューのツール(&T)の外部のツール1のショートカットキーを「F5」に変えろ

ショートカットに設定できるのは、Ctrl+[英数字]やファンクションキーです。

 

「もし」文の仕様変更

より自然な書き方でプログラムを記述できるように、TTSneo1.41以降では、もし文の文法を改良しました。
多くの場合、スペースによる分かち書きが不要になり、「以上」「より下」などの指定も柔軟になりました。

以前のバージョンでは、一度に複数の条件を指定する場合は、日本語表記(「以上」「以下」「より下」「より上」)を使用することができず、条件を数学的な表記で指定する必要がありましたが、1.41より日本語表記でも指定できるようになります。

従来

もし 数字は 10 以上なら
もし [数字>=10][数字<=20] なら

最新版

もし、数字が、10以上なら
もし [数字は、10以上][数字が 20以下] なら

※「○は □」や「〜は、□」の他に、「○が □」や「○が、□」を指定することも可能です

※従来の書き方でも正しく動作するように設計しておりますが、ベータ版では不具合がある可能性があります。

 

その他条件式を使う関数の改良

この変更と同時に、「判別」「配列判別」関数で指定する式も改良されました。
「もし」文の条件指定と同様に、「以上」「より下」などの日本語表記の指定が可能になり、" "で囲む特殊な条件にも対応しました。
また、複数の条件の指定(〜のどれかを除く)に対応しました。

’数が10以上で、9月より前なら「有効」と表示する
判別([数が、10以上][月は、9より下]、「有効」、「無効」)を表示

内容は、「APPLE,HOME,PEN,NOTEBOOK」
配列判別(内容、[文字数(それ)は、5以上])を表示

 

「分岐」文の仕様変更

「分岐」文で指定できる条件が拡張されました。
「もし」文の条件指定と同様に、「以上」「より下」などの日本語表記の指定が可能になり、" "で囲む特殊な条件にも対応しました。

数字は、10
数字について分岐
"文字"の場合
  「数字ではありません」を表示
5以下の場合
  「5以下です」を表示
10より下の場合
  「10未満です」を表示
10の場合
  「10です」を表示
10でないの場合
  「10ではありません」を表示
分岐終わり

また、「分岐」文に限り、以下のように、条件と命令を一行に記述することが可能になりました。

数字は、4
数字について分岐
1の場合 「Dです」を表示
2、3の場合 「Cです」を表示
4の場合 「Bです」を表示
5の場合 「Aです」を表示
分岐終わり

 

オリジナル命令の改良

オリジナル命令(手順)を実行する命令の書き方をより柔軟にしました。

従来は、オリジナル命令を呼び出すには、その手順名と完全に一致している必要がありましたが、
1.41より、他の命令と同様、「〜する」「〜しろ」と言った表現を指定することもできるようになりました。

従来

「データ」を処理
「データ」を処理しろ’動作しない

手順は 処理([変数]を)

終わり

最新版

「データ」を処理しろ’動作する
「データ」を処理する

手順は 処理([変数]を)

終わり

ただしオリジナル関数( 関数名(必要な情報) という形のもの)については、他の関数と同様、手順名と完全に一致している必要があります。