ホーム > TTSneoのお知らせ > 詳細

仕様の変更点

「選択されたファイル」関数の追加と「起動時設定(コマンドライン)」関数の結果の変更 ベータ7以降

「起動時設定」関数で表される結果を変更しました。
エクスプローラなどで渡されたコマンドラインのパラメータを、そのまま表すようになります。
今回の変更で、長いファイル名を指定した場合、" "が付加されるようになります。

関連付けや、実行可能ファイルへのファイルをドラッグ&ドロップして、処理をさせるプログラムの場合、
新しい関数「選択されたファイル」関数を利用してください。
この関数では、複数のファイルを選択した場合にも対応しています。

例 「C:\Program Files\TTSneo\はじめに.txt」を指定した場合

従来 C:\Program Files\TTSneo\はじめに.txt
新仕様 "C:\Program Files\TTSneo\はじめに.txt"

「メモ帳」サンプルの変更前

もし 起動時設定は 「」 でないなら 文章テキスト1の内容を開け(起動時設定)へ変えろ

「メモ帳」サンプルの変更後

もし 選択されたファイルは 「」 でないなら 文章テキスト1の内容を、開け(選択されたファイル)へ変えろ

オブジェクト配列 ベータ6以降

変数でオブジェクトの番号を、指定できる、オブジェクト配列の文法が変わります。
指定するときに、必ず変数を( )で囲む必要があります。

’従来
数字は、1
ボタン数字を作れ
ボタン[数字]の名前を、「OK」に変えろ

’新しい文法
数字は、1
ボタン(数字)を作れ
ボタン(数字)の名前を、「OK」に変えろ

構造体での浮動小数点数型に対応 ベータ5以降

辞書(構造体)で浮動小数点数型に対応しました。
「辞書初期化」命令で、変数名の前に「!」(Single型)、「%」(Double型)を指定することで、値として小数を受け渡しすることができます。

Test.dllのTestをTest(@メッセージ)として宣言

Dataを「%Value」で辞書初期化

内容は、Data
内容(「%Value」)は、3.141592
内容をTest

「宣言」命令では、浮動小数点数型に対応していません。

 

少し高速化

TTSneoの内部のプログラムを大幅に書き換えたことで、多少ではありますが、TTSneoの処理速度が向上しました。

パソコンの性能や状態によって異なりますが、TTSneo0.998と比べ約1.2倍、特に代入処理では最高で約3倍、高速化しました。

まだまだ市販言語に比べ速いとは言えませんが、より快適に利用することができるようになりました。

※プログラムの書き方によっては高速化が見込めない場合もあります

 

エクセル連携機能の強化

不便だったMicrosoft Excelとの連携機能を強化しました。

今までは、TTSneoのプログラムを起動した状態でないと、エクセルとの連携を行うことができませんでしたが、
「リンク」命令を使うことによって、すでに起動しているエクセルへの操作が可能になりました。

また、「エクセルのワークブック一覧」・「エクセルの現在ブックのワークシート一覧」設定項目を追加しました。
この設定項目を活用することで、より汎用性の高いツールをTTSneoで作ることが可能になります。

Excel連携の新機能・改良点

・すでに起動しているエクセルと連携する「リンク」命令
・セルに数式・関数式を指定可能に  「セルの計算式」設定項目
・「エクセルのワークブック一覧」「エクセルのワークブックのワークシート一覧」設定項目を追加
・図形・オートシェイプの取得が可能に  「エクセルの図形」オブジェクト
・一部、VBAのプロパティの設定と取得が可能に  コレクションの指定やメソッドは、仕様の問題で未対応

 ワークシートを適当に色付ける例

エラーは、無視
ウィンドウ1の表示
ウィンドウ1のボタン3をクリック
待機

手順は ウィンドウ1の表示
ウィンドウ1を使う
’<ウィンドウ1>
ウィンドウ1の中の大きさを312,266へ変えろ
  その名前を「エクセルシート色付け」へ変えろ
  その背景を&h8000000Fへ変えろ
  その種類を「固定」へ変えろ
  その最大化ボタンを0へ変えろ
リスト1を作れ
  その位置と大きさを20,30,270,80へ変えろ
リスト2を作れ
  その位置と大きさを20,140,270,80へ変えろ
ボタン1を作れ
  その位置と大きさを90,230,65,25へ変えろ
  その名前を「切り替え」へ変えろ
ボタン2を作れ
  その位置と大きさを180,230,110,25へ変えろ
  その名前を「色付け開始」へ変えろ
  そのエンターを1へ変えろ
ボタン3を作れ
  その位置と大きさを20,230,65,25へ変えろ
  その名前を「更新」へ変えろ
ラベル1を作れ
  その位置と大きさを10,10,99,12へ変えろ
  その内容を「対象のワークブック」へ変えろ
ラベル2を作れ
  その位置と大きさを10,120,100,12へ変えろ
  その内容を「対象のワークシート」へ変えろ
’</ウィンドウ1>
ウィンドウ1を表示
終わり
手順は ウィンドウ1のボタン1をクリック
エクセルをリンク
もし エクセルの起動中は、オフ なら 「エクセルを起動してください」を表示。手順から抜ける
エクセルのワークブックを、リスト1の内容に変えろ
エクセルのワークシートを、リスト2の内容に変えろ
終わり

手順は ウィンドウ1のリスト1をクリック
  エクセルのワークブックを、リスト1の内容に変えろ
  内容は、エクセルの現在ブックのワークシート一覧
  リスト2の一覧を、内容に変えろ
終わり
手順は ウィンドウ1のリスト2をクリック
  エクセルのワークシートを、リスト2の内容に変えろ
終わり

手順は ウィンドウ1のボタン3をクリック
エクセルをリンク
もし エクセルの起動中は、オフ なら 「エクセルを起動してください」を表示。手順から抜ける
もし エクセルの起動中は、オン なら
  内容は、エクセルのワークブック一覧
  リスト1の一覧を、内容に変えろ
もし終わり
終わり

手順は ウィンドウ1のボタン2をクリック
ウィンドウ1のボタン1をクリック
範囲は、入力(「処理範囲を指定してください。」、「10,10」)
もし 範囲は、「」 なら 手順から抜ける

範囲(1)回、横に1からカウントして繰り返せ
  範囲(2)¥2回、縦に1からカウントして繰り返せ
    エクセルのセル(横、縦*2)の背景を、黄緑に変えろ
  繰り返し終わり
繰り返し終わり

範囲(1)¥2回、横に1からカウントして繰り返せ
  範囲(2)回、縦に1からカウントして繰り返せ
    エクセルのセル(横*2、縦)の背景を、黄に変えろ
  繰り返し終わり
繰り返し終わり

終わり

 

TTSスタジオneoの改良

TTSスタジオの動作を安定させるために、タブ切り替え型に変更することにしました。

また、「ウィンドウの編集」の出力を見直しました。