ホーム > TTSneoのお知らせ > 詳細

TTSneoの新バージョン0.50では、「繰り返せ」「もし」命令など、すでにある命令も改良されました。
ぜひ、より使いやすくなった言語仕様を使ってください。

「繰り返せ」命令 ::::: "〜まで"と、「永遠に繰り返せ」でカウンタに対応

「繰り返せ」命令では、今まで回数を指定しないと繰り返しできませんでしたが、「〜まで」を指定することができるようになりました。

3から、6まで、数にカウントして、繰り返す
  数を、表示
繰り返し終わり

また、「永遠に」と指定すると、カウントができなかった問題を解消しました。

永遠に、数にカウントして、繰り返す
  数を、表示
  もし 数=5 なら 繰り返しから抜ける
繰り返し終わり

「もし」命令 ::::: 同時に複数の分岐が可能に

「もし」命令では、今まで、式が正しいときと違うときの2つしか分類できませんでしたが、「他でもし」とすることで、いくつもの分岐を行うことができます。
(VBのElseIfに似た使い方です)

返事は、質問(「保存しますか?」、はいといいえとキャンセル+質問)
もし 返事は、はい なら
  「はい」を表示
他でもし 返事は、いいえ なら
  「いいえ」を表示
でないなら
  「キャンセル」を表示
もし終わり

「ウィンドウ」オブジェクト ::::: 変形したウィンドウの作成が可能に

通常、ウィンドウは正方形ですが、TTSではウィンドウの形を定義した画像ファイルを読み込ませて「変形」設定項目をオンにすることで、ウィンドウを自由な形に変形することができます。

縁無しウィンドウを使う
  その大きさを350,100に変えろ
  その絵を「変形.bmp」に変えろ
  その変形をオンに変えろ
縁無しウィンドウを表示

「変形.bmp」に画像を読み込ませて、一番左上の1ピクセル目の色を透明部分として、判断して、ウィンドウの形を変形します。

詳しくは、サンプルの「はじめる」フォルダの「ウィンドウ」の「変形ウィンドウ.tts」をご覧ください。

「ツールバー」オブジェクト ::::: より細かく設定可能に

ボタンに文字列を表示させたり、チップヘルプを設定したり、チェックや有効かを設定したりするなど、各ボタンの細かい設定が可能になりました。

ツールバー1を作れ
  それに「-」を追加
  それに「File.ico」で追加
  それに「File.ico」で追加
  その2番目のヒントを、「ファイル」に変えろ
  その2番目のチェックを、オンに変えろ
  その2番目のスタイルを、1に変えろ
  その3番目の有効を、オフに変えろ

オリジナル命令 ::::: 助詞を自由に定義可能に

以前から、手順を使ってオリジナルの手順が作成できましたが、新バージョンでは「〜に」「〜で」といった助詞を定義することができるようになりました。
このことで、オリジナル命令でもTTSの命令と同様に自然な日本語にオリジナル命令を使うことができるようになりました。

「メッセージ」を「人」に処理

手順は 処理([名詞,[目的語
  名詞を表示
  目的語を表示
終わり

説明
手順名に続いて"([変数1]助詞1,[変数2]助詞2・・・)"という形で、指定しておきます。
そうすると、手順を呼び出したときに、助詞に対応する変数に、内容が保存されます。

新バージョンで改良された機能は、以上のものがありますが、TTSneoは改良されています。
あなたの知らないうちに、便利な命令・関数などが追加されている可能性があります。

サンプルやマニュアル・クイックヘルプなどをよく見てください。
きっと新発見があると思います!